Вопрос - Ответ

Hellius

Активный участник
#52
Подскажите пожалуйста, у меня 2 сети (назовем IP1 и IP2).
Я поставил вебсервер XAMPP, и на него поставил форум phpbb3.
После всех манипуляций, когда получилось добиться стабильной работы, люди на него могут зайти только с адресов IP1/phpbb3 и IP2/phpbb3
Как можно сделать или что можно сделать подскажите, что бы люди просто в браузере вводили Ип адрес, одной из сети и сразу попадали на форум? Без приписки phpbb3?
Сейчас если они просто вводят Ип, они пытаются попасть как я понял на учетку XAMPP и их просит ввести логин пороль.
Заранее большое спасибо!
 

Saps

Активный участник
#53
Подскажите пожалуйста, у меня 2 сети (назовем IP1 и IP2).
Я поставил вебсервер XAMPP, и на него поставил форум phpbb3.
После всех манипуляций, когда получилось добиться стабильной работы, люди на него могут зайти только с адресов IP1/phpbb3 и IP2/phpbb3
Как можно сделать или что можно сделать подскажите, что бы люди просто в браузере вводили Ип адрес, одной из сети и сразу попадали на форум? Без приписки phpbb3?
Сейчас если они просто вводят Ип, они пытаются попасть как я понял на учетку XAMPP и их просит ввести логин пороль.
Заранее большое спасибо!
Можно в конфиге апача прописать название файла, которое открывается при заходе в директиву, в которой он лежит. Сделай в папке с сайтами файл (к примеру, index.php) и сделай переадресацию на ип/пхпбб3/
 

Dekond

Активный участник
#54
при запуске Vertrigo выдаёт ошибку , что заняты порты 80 либо 3306 , при это сайт работает , но не работает база данных . вроде бы надо что то включать в службах , вот только что
 

Saps

Активный участник
#55
при запуске Vertrigo выдаёт ошибку , что заняты порты 80 либо 3306 , при это сайт работает , но не работает база данных . вроде бы надо что то включать в службах , вот только что
Тс сервер может мешать. Порт апача измени, проблемы не будет. Или же какой-то другой сервер поставь на иной порт.
 

Dekond

Активный участник
#56
я уже менял порты на любые другие . я помню , что то в службах надо было включать / выключать . не могу поставить другой веб сервер мне от туда базы нужны
 

Saps

Активный участник
#57
я уже менял порты на любые другие . я помню , что то в службах надо было включать / выключать . не могу поставить другой веб сервер мне от туда базы нужны
А сменить веб сервер + экспортировать бд с прошлого сервера баз данных и импортировать в новый - не вариант?
А по поводу сервера баз данных - если веб сервер запускается, а сервер бд нет, то проблема в портах именно сервера бд. Меняй их и прописывай в конфигах.
 

Dekond

Активный участник
#58
А сменить веб сервер + экспортировать бд с прошлого сервера баз данных и импортировать в новый - не вариант?
А по поводу сервера баз данных - если веб сервер запускается, а сервер бд нет, то проблема в портах именно сервера бд. Меняй их и прописывай в конфигах.
я уже сменил бд . и проблема была не в портах я их менял уже с десяток раз . в службах было половина отключена . и включены брандмауэр и встроенный антивирус
 

Saps

Активный участник
#59
я уже сменил бд . и проблема была не в портах я их менял уже с десяток раз . в службах было половина отключена . и включены брандмауэр и встроенный антивирус
В брандмауэре нужно делать исключение на проверку веб сервера или уж совсем отключать его самого. Брандмауэр блокирует веб сервер.
 

Saps

Активный участник
#61

JlieNe

Активный участник
#62
У него компоненты сервера установлены как службы. На 8ке. В жопу таких слать надо, вот и решение проблемы. Понаустанавливают херни на свои компьютеры, а потом ноют на форумах почему у них нихрена не работает.
 

Dekond

Активный участник
#63
У него компоненты сервера установлены как службы. На 8ке. В жопу таких слать надо, вот и решение проблемы. Понаустанавливают херни на свои компьютеры, а потом ноют на форумах почему у них нихрена не работает.
как бы это AppServ . мне как то делали , что всё работало .
Если честно, не понял, что за службы. Ты здесь запускаешь установку апача и следишь за ней через консоль. Ты один апач отдельно устанавливаешь?
вся эта магия батника выглядит примерно так
Код:
@ECHO OFF
 
if "%OS%" == "Windows_NT" goto WinNT
 
:Win9X
ECHO.
ECHO #######  Sorry! Apache can not run as Services under Win9x  #######
ECHO #######  Please use apache_start.bat instead  #######
ECHO.
goto exit
 
:WinNT
ECHO.
ECHO #######  Installing Apache as an Service  #######
ECHO #######  To remove Service please use : apache_serviceuninstall.bat  #######
ECHO.
bin\httpd -k install  -n "Apache2.2"
 
ECHO.
ECHO ####### Now Starting Apache...  #######
ECHO.
net start Apache2.2
 
:exit
ECHO.
pause
 

Saps

Активный участник
#65
Да, видимо, он не знал, что можно поставить на 8-ку. У меня самого 8-я винда, ставил и опенсервер, и вертриго. Ну, понятно, это сборки, а отдельно апач не ставил (на 7-й только).
как бы это AppServ . мне как то делали , что всё работало .
А, так это к тебе я в БД залазил.